Wissen

OpenWRT Router als Repeater nutzen – Anleitung

HowTo: Konfiguration eines OpenWRT Systems als Repeater

OpenWRT ist ein offenes und kostenloses Router Betriebssystem, welches man auf viele unterstützte Router Hardware installieren kann um so unter Umständen mehr Leistung aus dem Endgerät zu kitzeln und den Funktionsumfang zu erweitern. Eine wahrscheinlich sehr oft benötigte Funktionalität ist der Einsatz als Repeater und die Reichweite eines WLAN Netzwerkes zu vergrößern. Damit zapft man sozusagen das WiFi-Netzwerk von Router 1 an und gibt dieses über den zweiten Router an die Clients aus!

Beispiel aus der Praxis: Ein Router befindet sich im Erdgeschoss und versorgt das Erdgeschoss mit WLAN. Das erste Stockwerk ist ebenfalls noch über diesen Router mit WLAN abgedeckt, doch bis auf dem Dachboden reicht die Sendeleistung nicht mehr aus. Jetzt setzt man einfach im ersten Stockwerk einen Repeater ein, welcher sich nun um eine verbesserte WiFi Abdeckung im ersten Stock und am Dachboden kümmert.

Und so funktioniert es:

Diese Anleitung erfolgt über das Userinterface, jedoch werde ich Euch gegen Ende noch einen Auszug aus den Konfigurationsfiles posten! Es soll ja Leute geben welche lieber über die Kommandozeile arbeiten! ;)

 

Schritt 1: Auf Network –> Wifi gehen
Jetzt sieht man hier die aktivierte Wifi Verbindung für einen normalen AP!
Hier benötigen wir nun eine zweite Verbindung, welche den Connect zum „Haupt-Router“ herstellt.

Die einfachste Möglichkeit dabei ist die Scan-Funktion der Software zu nutzen!

 

OpenWRT-Router-Repeater-Konfiguration (1)

 

Jetzt werden Euch alle verfügbaren Netzwerke angezeigt! Hier wählt ihr nun das Netzwerk aus, mit dem ihr Euch verbinden wollt!

 

OpenWRT-Router-Repeater-Konfiguration (2)

 

Jetzt öffnet sich die Maske über welche ihr das Passwort für Euer Hauptnetzwerk hinterlegen müsst. Als Firewallzone wählt ihr wan aus – da diese Verbindung nach extern weiter routet!

 

OpenWRT-Router-Repeater-Konfiguration (3)

 

Einstellen checken – speichern!!

 

OpenWRT-Router-Repeater-Konfiguration (4)

 

Einstellungen werden übernommen!

 

OpenWRT-Router-Repeater-Konfiguration (5)

 

Schritt 2: Die Firewallregeln checken!

Im Prinzip könnt ihr hier alles aktivieren!

 

OpenWRT-Router-Repeater-Konfiguration (6)

 

 

Schritt 3: Kein wirklicher Schritt – aber nochmals eine kleine Zusammenfassung

Die Einstellungen des normalen AP-Netzwerkes über welches sich die Clients am Router 2, welcher den Repeater spielt, anmelden.

 

OpenWRT-Router-Repeater-Konfiguration (7)

 

OpenWRT-Router-Repeater-Konfiguration (8)

 

Das zweite WLAN Interface, welches die Verbindung zu Hauptrouter aufbaut!

 

OpenWRT-Router-Repeater-Konfiguration (9)

 

OpenWRT-Router-Repeater-Konfiguration (10)

 

Fertig!
Der Router mit dem OpenWRT Betriebssystem sollte nun Repeater spielen!

 

Hier noch die oben versprochenen Config-Files!

/etc/config/network

config interface ‚loopback‘
        option ifname ‚lo‘
        option proto 'static‘
        option ipaddr ‚127.0.0.1‘
        option netmask ‚255.0.0.0‘

config interface ‚lan‘
        option ifname ‚eth0‘
        option type ‚bridge‘
        option proto 'static‘
        option ipaddr ‚192.168.1.1‘
        option netmask ‚255.255.255.0‘

config interface ‚wwan‘
        option proto ‚dhcp‘

 

 

/etc/config/wireless

 

config wifi-device ‚radio0‘
        option type ‚mac80211‘
        option macaddr ‚6c:e8:73:d2:7c:a0‘
        option hwmode '11ng‘
        option htmode ‚HT20‘
        list ht_capab ‚SHORT-GI-20‘
        list ht_capab ‚SHORT-GI-40‘
        list ht_capab ‚RX-STBC1‘
        list ht_capab ‚DSSS_CCK-40‘
        option txpower '27‘
        option country ‚US‘
        option channel ‚2‘
        option disabled ‚0‘

config wifi-iface
        option device ‚radio0‘
        option mode ‚ap‘
        option ssid ‚ITler-703‘
        option network ‚lan‘
        option encryption ‚psk2‘
        option key ‚itlernet‘

config wifi-iface
        option network ‚wwan‘
        option ssid ‚ITler‘
        option encryption ‚psk2‘
        option device ‚radio0‘
        option mode 'sta‘
        option bssid '00:13:10:14:C2:CD‘
        option key ‚itlernet‘

 

 

/etc/config/firewall

 

config defaults
        option syn_flood ‚1‘
        option input ‚ACCEPT‘
        option output ‚ACCEPT‘
        option forward ‚ACCEPT‘

config zone
        option name ‚lan‘
        option input ‚ACCEPT‘
        option output ‚ACCEPT‘
        option forward ‚ACCEPT‘
        option network ‚lan‘

config zone
        option name ‚wan‘
        option output ‚ACCEPT‘
        option masq ‚1‘
        option mtu_fix ‚1‘
        option input ‚ACCEPT‘
        option forward ‚ACCEPT‘
        option network ‚wan wwan‘

config forwarding
        option src ‚lan‘
        option dest ‚wan‘

config rule
        option name ‚Allow-DHCP-Renew‘
        option src ‚wan‘
        option proto ‚udp‘
        option dest_port '68‘
        option target ‚ACCEPT‘
        option family ‚ipv4‘

config rule
        option name ‚Allow-Ping‘
        option src ‚wan‘
        option proto ‚icmp‘
        option icmp_type ‚echo-request‘
        option family ‚ipv4‘
– firewall 1/92 1%

config rule
        option name ‚Allow-DHCPv6‘
        option src ‚wan‘
        option proto ‚udp‘
        option src_ip ‚fe80::/10‘
        option src_port ‚547‘
        option dest_ip ‚fe80::/10‘
        option dest_port ‚546‘
        option family ‚ipv6‘
        option target ‚ACCEPT‘

config rule
        option name ‚Allow-ICMPv6-Input‘
        option src ‚wan‘
        option proto ‚icmp‘
        list icmp_type ‚echo-request‘
        list icmp_type ‚echo-reply‘
        list icmp_type ‚destination-unreachable‘
        list icmp_type ‚packet-too-big‘
        list icmp_type ‚time-exceeded‘
        list icmp_type ‚bad-header‘
        list icmp_type ‚unknown-header-type‘
        list icmp_type ‚router-solicitation‘
        list icmp_type 'neighbour-solicitation‘
        list icmp_type ‚router-advertisement‘
        list icmp_type 'neighbour-advertisement‘
        option limit ‚1000/sec‘
        option family ‚ipv6‘
        option target ‚ACCEPT‘

config rule
        option name ‚Allow-ICMPv6-Forward‘
        option src ‚wan‘
        option dest ‚*‘
        option proto ‚icmp‘
        list icmp_type ‚echo-request‘
        list icmp_type ‚echo-reply‘
        list icmp_type ‚destination-unreachable‘
        list icmp_type ‚packet-too-big‘
        list icmp_type ‚time-exceeded‘
        list icmp_type ‚bad-header‘
        list icmp_type ‚unknown-header-type‘
        option limit ‚1000/sec‘
        option family ‚ipv6‘
        option target ‚ACCEPT‘

config include
        option path ‚/etc/firewall.user‘


Tags:

  • open wrt wlan repeater
  • router für open wrt wlan client
  • wlan router openwrt bridge
  • Open wrt repeater anleitung
  • anleitung openwrt
Tags

Related Articles

Kommentar verfassen

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Back to top button
Close
Send this to a friend