Wissen

IonCube installieren – Apache, Linux, PHP

Hier eine kleine Info wie man für PHP Programme welche auf die Zend Extension IonCube aufsetzen IonCube auf seinen eigenen Server oder VServer installieren kan.

Zuerst sollte man in ein passendes Verzeichnis wechseln:

cd /usr/local/

Als nächstes besucht ihr die Seite von Ioncube und kopiert euch den passenden Download-Link für Euer System.

Jetzt sprint ihr wieder in die Konsole zurück und startet den Download über folgenden Befehl:

wget (http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz) <-- Link durch eigenen ersetzen

Jetzt muss der Inhalt noch entpackt werden:

tar -xvzf ioncube_loaders_lin_x86-64.tar.gz <--> eigenen Link angeben!!

Damit das Modul auch gestartet wird, müssen wir dem PHP System, die Veränderung in der php.ini mitteilen!

Navigiert in den passenden PHP Ordner z.B.

cd /etc/php/php5

Dort öffnet ihr die php.ini mit einem Editor z.B.

vi php.ini

Nun navigiert ihr am einfachsten ganz zum Ende des Dokumentes und fügt dort folgdende Zeie ein:

zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so

Hier kann der Pfad auch leicht abweichen, je nach Version, welche installiert wurde!

Die php.ini abspeichern und den Apache-Server stoppen und wieder starten!

z.B.

/etc/init.d/apache2 stop
/etc/init.d/apache2 start

In der PHP Info könnt ihr nun das Zend Modul ersehen!

Randinfo: Sollten mehrere Zend Extensions am Server installiert sein, muss der Aufruf von IonCube vor den anderen Extensions stehen!


Tags:

  • apache ioncube installieren
  • file extension so ioncube
  • apache ioncube
  • ioncube loader linux
  • php ini download ioncube
Tags

Related Articles

3 Comments

  1. Hab alles befolgt, jedoch scheint es nciht zu laufen!
    Wie kann ich testen ob das ding da läuft?
    Weil habe hier was aufm Server isntalleirt und bekomme die Ausgabe: „Site error: the file /srv/www/vhosts/meinedomain.net/httpdocs/index.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.“

    Und ich denke das dingen hier ist wohl gemeint.
    Und muss ich das als root machen oder für jeden Webuser?

  2. Hallo gibt es ioncubloader nicht für raspberrry 3 ? Kann ich nicht einfach in rassbian jessi auf 32 bit umstellen ?

Kommentar verfassen

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Back to top button
Close
Send this to a friend